ARD Order failures June 27 and 28, 2022
Incident Report for ARD
Resolved
This incident has been resolved.
Posted Jun 29, 2022 - 20:03 UTC
Identified
ARD is experiencing a high volume of order failures. We will reach out to impacted customers individually with next steps.
Posted Jun 28, 2022 - 14:49 UTC